Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Pierre Dubuc <pldubuc <at> yahoo.ca>
Subject: Status of math_emulate
Newsgroups: gmane.os.netbsd.ports.i386
Date: Sunday 25th February 2007 00:17:17 UTC (over 10 years ago)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I see some old posts on the lists about the math_emulate option. Some 
posts suggest that at one point, the emulation was somehow incomplete.


I just installed NetBSD-3.1 (i386) on a 486 with the following dmesg:

NetBSD 3.1 (GENERIC) #0: Tue Oct 31 04:27:07 UTC 2006

[email protected]:/home/builds/ab/netbsd-3-1-RELEASE/i386/20061030
2053Z-obj/home/builds/ab/netbsd-3-1-RELEASE/src/sys/arch/i386/compile/
GENERIC
total memory = 15616 KB
avail memory = 6820 KB
mainbus0 (root)
cpu0 at mainbus0: (uniprocessor)
cpu0: Intel 486DX (486-class)
isa0 at mainbus0
lpt0 at isa0 port 0x378-0x37b irq 7
com0 at isa0 port 0x3f8-0x3ff irq 4: ns8250 or ns16450, no fifo
com1 at isa0 port 0x2f8-0x2ff irq 3: ns8250 or ns16450, no fifo
pckbc0 at isa0 port 0x60-0x64
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard
wdc0 at isa0 port 0x1f0-0x1f7 irq 14
atabus0 at wdc0 channel 0
we1 at isa0 port 0x300-0x31f iomem 0xcc000-0xcdfff irq 10
we1: SMC8416T Ethernet (16-bit)
we1: Ethernet address 00:e0:29:16:74:09
vga0 at isa0 port 0x3b0-0x3df iomem 0xa0000-0xbffff
wsdisplay0 at vga0 kbdmux 1: console (80x25, vt100 emulation), using 
wskbd0
wsmux1: connecting to wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: PC speaker
sysbeep0 at pcppi0
isapnp0 at isa0 port 0x279: ISA Plug 'n Play device support
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
isapnp0: no ISA Plug 'n Play devices found
fd0 at fdc0 drive 0: 1.44MB, 80 cyl, 2 head, 18 sec
Kernelized RAIDframe activated
wd0 at atabus0 drive 0: 
wd0: drive supports 16-sector PIO transfers, chs addressing
wd0: 515 MB, 1048 cyl, 16 head, 63 sec, 512 bytes/sect x 1056384 sectors
wd0: drive supports PIO mode 3
boot device: wd0
root on wd0a dumps on wd0b
root file system type: ffs
wsdisplay0: screen 1 added (80x25, vt100 emulation)
wsdisplay0: screen 2 added (80x25, vt100 emulation)
wsdisplay0: screen 3 added (80x25, vt100 emulation)
wsdisplay0: screen 4 added (80x25, vt100 emulation)


If I attempt to run commands like "ping" or "top" I sometimes get 
crashes (core dumped) or error messages. ping, specifically, fails every
time with the message "math_emulate: 0xd9fa not implemented - Illegal
instruction". I'm running the GENERIC kernel, so I'm wondering if I
require something else, or if the emulation is still broken.


- -- 
Pierre Dubuc
[email protected]
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (NetBSD)

iEYEARECAAYFAkXg1ZkACgkQaMA1iJ2qYmLMJACg/eJheahSkrhVEUTd7WVUaiBQ
3rsAn2SIroLfzoQXqZ0SYKLLuiQtJZZp
=T5/O
-----END PGP SIGNATURE-----
 
CD: 3ms