Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Aaron J. Grier <agrier <at> poofygoof.com>
Subject: AMD GX3 geode support
Newsgroups: gmane.os.netbsd.ports.i386
Date: Tuesday 1st August 2006 01:13:45 UTC (over 11 years ago)
I've got an geode-based IEI WAFER LX 800 3.5" single-board-computer [1]
it boots and (mostly) runs NetBSD-3, but has some showstopping caveats
for my application.

I've attached the full dmesg, but here's the bits that concern me:

* IDE support:

pciide0 at pci0 dev 15 function 2
pciide0: Advanced Micro Devices product 0x209a (rev. 0x01)
pciide0: bus-master DMA support present, but unused (no driver support)
pciide0: primary channel wired to compatibility mode
pciide0: primary channel ignored (other hardware responding at addresses)
pciide0: secondary channel wired to compatibility mode
pciide0: secondary channel ignored (not responding; disabled or no drives?)

performance is poor, as expected.  but it does work.

* audio:

Advanced Micro Devices product 0x2093 (audio multimedia, revision 0x01) at
pci0 dev 15 function 3 not configured

the codec is an avance logic (realtek) ALC203.  I assume only the glue
to the AC97 bus is missing to get this working.

this is a showstopper for my application.

* floating point:

npx0 at isa0 port 0xf0-0xff: error reporting broken; not using

coincidentally, lack of FPU triggers the long-standing PR6986 [2].  gcc
is _still_ producing floating point ops in userland that the kernel
can't emulate.  this keeps me from trying X as well.

[1] http://www.ieiworld.com/en/product_IPC.asp?model=WAFER-LX
[2] http://www.netbsd.org/cgi-bin/query-pr-single.pl?number=6986

-- 
  Aaron J. Grier | "Not your ordinary poofy goof." | [email protected]
              "silly brewer, saaz are for pils!"  --  virt
 
CD: 3ms