Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: James Collier <james.collier412 <at> gmail.com>
Subject: GNU emacs on Hurd
Newsgroups: gmane.os.hurd.bugs
Date: Thursday 5th July 2012 07:41:48 UTC (over 4 years ago)
Hi,
My apologies if this is the incorrect forum for this. I appreciate being
corrected.
I should quickly introduce myself as this is my first post. I've been
subscribed on this list for several years and have been very interested
in the GNU/Hurd. I would very much like to see (and help) it released in
Debian Wheezy.
Anyway, onto my problem. I have recently installed Debian GNU/Hurd from
the debian installer images at
http://people.debian.org/~sthibault/hurd-i386/installer/cdimage/

Firstly, networking works but `devprobe eth0' doesn't return anything.
Secondly, and the reason for this email, emacs refuses to start. After
some googling I found:
http://lists.gnu.org/archive/html/bug-gnu-emacs/2011-04/msg00140.html

Trying to start emacs from the hurd console results in the message:
$ emacs
emacs: Not a tty device: /dev/tty

$emacs -nw
emacs: Not a tty device: /dev/tty

$ emacs --version
GNU Emacs 23.2.1

$ apt-cache policy emacs
emacs:
  Installed: 24.1+1-1
  Candidate: 24.1+1-1
  Version table:
 *** 24.1+1-1 0
        500 http://ftp.debian.org/debian/
sid/main hurd-i386 Packages
        100 /var/lib/dpkg/status
     23.2+1-7 0
        500 http://ftp.debian.org/debian/
sid/main hurd-i386 Packages

I would appreciate some advice on what to do next. Should I forward the
bug to Debian (I can't find it on the debian bug tracker) with the
patch?

Thanks very much,

James
 
CD: 3ms