Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Marc Deslauriers <marc.deslauriers <at> canonical.com>
Subject: [USN-1866-1] libxtst vulnerability
Newsgroups: gmane.linux.ubuntu.security.announce
Date: Wednesday 5th June 2013 18:30:10 UTC (over 3 years ago)
==========================================================================
Ubuntu Security Notice USN-1866-1
June 05, 2013

libxtst vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 13.04
- Ubuntu 12.10
- Ubuntu 12.04 LTS
- Ubuntu 10.04 LTS

Summary:

Several security issues were fixed in libxtst.

Software Description:
- libxtst: X11 Record extension library

Details:

Ilja van Sprundel discovered multiple security issues in various X.org
libraries and components. An attacker could use these issues to cause
applications to crash, resulting in a denial of service, or possibly
execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 13.04:
  libxtst6                        2:1.2.1-1ubuntu0.13.04.1

Ubuntu 12.10:
  libxtst6                        2:1.2.1-1ubuntu0.12.10.1

Ubuntu 12.04 LTS:
  libxtst6                        2:1.2.0-4ubuntu0.1

Ubuntu 10.04 LTS:
  libxtst6                        2:1.1.0-2ubuntu0.1

After a standard system update you need to restart your session to make all
the necessary changes.

References:
  http://www.ubuntu.com/usn/usn-1866-1
  CVE-2013-2063

Package Information:
  https://launchpad.net/ubuntu/+source/libxtst/2:1.2.1-1ubuntu0.13.04.1
  https://launchpad.net/ubuntu/+source/libxtst/2:1.2.1-1ubuntu0.12.10.1
  https://launchpad.net/ubuntu/+source/libxtst/2:1.2.0-4ubuntu0.1
  https://launchpad.net/ubuntu/+source/libxtst/2:1.1.0-2ubuntu0.1
 
CD: 5ms