Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: <riehecky-13hema8v3vg <at> public.gmane.org>
Subject: Security ERRATA Moderate: ghostscript on SL5.x, SL6.x i386/x86_64
Newsgroups: gmane.linux.scientific.errata
Date: Friday 3rd February 2012 15:54:15 UTC (over 4 years ago)
Synopsis:    Moderate: ghostscript security update
Issue Date:  2012-02-02
CVE Numbers: CVE-2010-2055
             CVE-2009-3743
             CVE-2010-4054
             CVE-2010-4820


Ghostscript is a set of software that provides a PostScript interpreter, a
set of C procedures (the Ghostscript library, which implements the graphics
capabilities in the PostScript language) and an interpreter for Portable
Document Format (PDF) files.

An integer overflow flaw was found in Ghostscript's TrueType bytecode
interpreter. An attacker could create a specially-crafted PostScript or PDF
file that, when interpreted, could cause Ghostscript to crash or,
potentially, execute arbitrary code. (CVE-2009-3743)

It was found that Ghostscript always tried to read Ghostscript system
initialization files from the current working directory before checking
other directories, even if a search path that did not contain the current
working directory was specified with the "-I" option, or the "-P-" option
was used (to prevent the current working directory being searched first).
If a user ran Ghostscript in an attacker-controlled directory containing a
system initialization file, it could cause Ghostscript to execute arbitrary
PostScript code. (CVE-2010-2055)

Ghostscript included the current working directory in its library search
path by default. If a user ran Ghostscript without the "-P-" option in an
attacker-controlled directory containing a specially-crafted PostScript
library file, it could cause Ghostscript to execute arbitrary PostScript
code. With this update, Ghostscript no longer searches the current working
directory for library files by default. (CVE-2010-4820)

Note: The fix for CVE-2010-4820 could possibly break existing
configurations. To use the previous, vulnerable behavior, run Ghostscript
with the "-P" option (to always search the current working directory
first).

A flaw was found in the way Ghostscript interpreted PostScript Type 1 and
PostScript Type 2 font files. An attacker could create a specially-crafted
PostScript Type 1 or PostScript Type 2 font file that, when interpreted,
could cause Ghostscript to crash or, potentially, execute arbitrary code.
(CVE-2010-4054)

Users of Ghostscript are advised to upgrade to these updated packages,
which contain backported patches to correct these issues.

SL5:
  i386
     ghostscript-8.70-6.el5_7.6.i386.rpm
     ghostscript-debuginfo-8.70-6.el5_7.6.i386.rpm
     ghostscript-devel-8.70-6.el5_7.6.i386.rpm
     ghostscript-gtk-8.70-6.el5_7.6.i386.rpm
  x86_64
     ghostscript-8.70-6.el5_7.6.i386.rpm
     ghostscript-8.70-6.el5_7.6.x86_64.rpm
     ghostscript-debuginfo-8.70-6.el5_7.6.i386.rpm
     ghostscript-debuginfo-8.70-6.el5_7.6.x86_64.rpm
     ghostscript-devel-8.70-6.el5_7.6.i386.rpm
     ghostscript-devel-8.70-6.el5_7.6.x86_64.rpm
     ghostscript-gtk-8.70-6.el5_7.6.x86_64.rpm
SL6:
  i386
     ghostscript-8.70-11.el6_2.6.i686.rpm
     ghostscript-debuginfo-8.70-11.el6_2.6.i686.rpm
     ghostscript-devel-8.70-11.el6_2.6.i686.rpm
     ghostscript-doc-8.70-11.el6_2.6.i686.rpm
     ghostscript-gtk-8.70-11.el6_2.6.i686.rpm
  x86_64
     ghostscript-8.70-11.el6_2.6.i686.rpm
     ghostscript-8.70-11.el6_2.6.x86_64.rpm
     ghostscript-debuginfo-8.70-11.el6_2.6.i686.rpm
     ghostscript-debuginfo-8.70-11.el6_2.6.x86_64.rpm
     ghostscript-devel-8.70-11.el6_2.6.i686.rpm
     ghostscript-devel-8.70-11.el6_2.6.x86_64.rpm
     ghostscript-doc-8.70-11.el6_2.6.x86_64.rpm
     ghostscript-gtk-8.70-11.el6_2.6.x86_64.rpm

- Scientific Linux Development Team
 
CD: 3ms