Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Pat Riehecky <riehecky-13hema8v3vg <at> public.gmane.org>
Subject: Security ERRATA Moderate: rubygems on SL6.x (noarch)
Newsgroups: gmane.linux.scientific.errata
Date: Thursday 17th October 2013 19:26:46 UTC (over 2 years ago)
Synopsis:          Moderate: rubygems security update
Advisory ID:       SLSA-2013:1441-1
Issue Date:        2013-10-17
CVE Numbers:       CVE-2012-2125
                   CVE-2012-2126
                   CVE-2013-4287
--

It was found that RubyGems did not verify SSL connections. This could lead
to man-in-the-middle attacks. (CVE-2012-2126)

It was found that, when using RubyGems, the connection could be redirected
from HTTPS to HTTP. This could lead to a user believing they are
installing a gem via HTTPS, when the connection may have been silently
downgraded to HTTP. (CVE-2012-2125)

It was discovered that the rubygems API validated version strings using an
unsafe regular expression. An application making use of this API to
process a version string from an untrusted source could be vulnerable to a
denial of service attack through CPU exhaustion. (CVE-2013-4287)
--

SL6
  noarch
    rubygems-1.3.7-4.el6_4.noarch.rpm

- Scientific Linux Development Team
 
CD: 3ms