Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Pat Riehecky <riehecky-13hema8v3vg <at> public.gmane.org>
Subject: Security ERRATA Important: kernel on SL5.x i386/x86_64
Newsgroups: gmane.linux.scientific.errata
Date: Wednesday 21st August 2013 13:44:01 UTC (over 3 years ago)
Synopsis:          Important: kernel security and bug fix update
Advisory ID:       SLSA-2013:1166-1
Issue Date:        2013-08-20
CVE Numbers:       CVE-2013-2147
                   CVE-2013-2164
                   CVE-2013-2206
                   CVE-2013-2224
                   CVE-2013-2234
                   CVE-2013-2237
                   CVE-2013-2232
--

This update fixes the following security issues:

* A flaw was found in the way the Linux kernel's Stream Control
Transmission Protocol (SCTP) implementation handled duplicate cookies. If
a local user queried SCTP connection information at the same time a remote
attacker has initialized a crafted SCTP connection to the system, it could
trigger a NULL pointer dereference, causing the system to crash.
(CVE-2013-2206, Important)

* It was found that the fix for CVE-2012-3552 released via SLSA-2012:1540
introduced an invalid free flaw in the Linux kernel's TCP/IP protocol
suite implementation. A local, unprivileged user could use this flaw to
corrupt kernel memory via crafted sendmsg() calls, allowing them to cause
a denial of service or, potentially, escalate their privileges on the
system. (CVE-2013-2224, Important)

* An invalid pointer dereference flaw was found in the Linux kernel's
TCP/IP protocol suite implementation. A local, unprivileged user could use
this flaw to crash the system or, potentially, escalate their privileges
on the system by using sendmsg() with an IPv6 socket connected to an IPv4
destination. (CVE-2013-2232, Moderate)

* Information leak flaws in the Linux kernel could allow a privileged,
local user to leak kernel memory to user-space. (CVE-2013-2164,
CVE-2013-2147, CVE-2013-2234, CVE-2013-2237, Low)

The system must be rebooted for this update to take effect.
--

SL5
  x86_64
    kernel-2.6.18-348.16.1.el5.x86_64.rpm
    kernel-debug-2.6.18-348.16.1.el5.x86_64.rpm
    kernel-debug-debuginfo-2.6.18-348.16.1.el5.x86_64.rpm
    kernel-debug-devel-2.6.18-348.16.1.el5.x86_64.rpm
    kernel-debuginfo-2.6.18-348.16.1.el5.x86_64.rpm
    kernel-debuginfo-common-2.6.18-348.16.1.el5.x86_64.rpm
    kernel-devel-2.6.18-348.16.1.el5.x86_64.rpm
    kernel-headers-2.6.18-348.16.1.el5.x86_64.rpm
    kernel-xen-2.6.18-348.16.1.el5.x86_64.rpm
    kernel-xen-debuginfo-2.6.18-348.16.1.el5.x86_64.rpm
    kernel-xen-devel-2.6.18-348.16.1.el5.x86_64.rpm
  i386
    kernel-2.6.18-348.16.1.el5.i686.rpm
    kernel-PAE-2.6.18-348.16.1.el5.i686.rpm
    kernel-PAE-debuginfo-2.6.18-348.16.1.el5.i686.rpm
    kernel-PAE-devel-2.6.18-348.16.1.el5.i686.rpm
    kernel-debug-2.6.18-348.16.1.el5.i686.rpm
    kernel-debug-debuginfo-2.6.18-348.16.1.el5.i686.rpm
    kernel-debug-devel-2.6.18-348.16.1.el5.i686.rpm
    kernel-debuginfo-2.6.18-348.16.1.el5.i686.rpm
    kernel-debuginfo-common-2.6.18-348.16.1.el5.i686.rpm
    kernel-devel-2.6.18-348.16.1.el5.i686.rpm
    kernel-headers-2.6.18-348.16.1.el5.i386.rpm
    kernel-xen-2.6.18-348.16.1.el5.i686.rpm
    kernel-xen-debuginfo-2.6.18-348.16.1.el5.i686.rpm
    kernel-xen-devel-2.6.18-348.16.1.el5.i686.rpm
  noarch
    kernel-doc-2.6.18-348.16.1.el5.noarch.rpm

- Scientific Linux Development Team
 
CD: 4ms