Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Pat Riehecky <riehecky-13hema8v3vg <at> public.gmane.org>
Subject: Security ERRATA Important: libxml2 on SL5.x, SL6.x i386/x86_64
Newsgroups: gmane.linux.scientific.errata
Date: Thursday 29th November 2012 21:44:31 UTC (over 4 years ago)
Synopsis:          Important: libxml2 security update
Issue Date:        2012-11-29
CVE Numbers:       CVE-2012-5134
--

A heap-based buffer underflow flaw was found in the way libxml2 decoded
certain entities. A remote attacker could provide a specially-crafted XML
file that, when opened in an application linked against libxml2, would
cause the application to crash or, potentially, execute arbitrary code with
the privileges of the user running the application. (CVE-2012-5134)

The desktop must be restarted (log out, then log back in) for this update
to take effect.
--

SL5
   x86_64
     libxml2-2.6.26-2.1.15.el5_8.6.i386.rpm
     libxml2-2.6.26-2.1.15.el5_8.6.x86_64.rpm
     libxml2-debuginfo-2.6.26-2.1.15.el5_8.6.i386.rpm
     libxml2-debuginfo-2.6.26-2.1.15.el5_8.6.x86_64.rpm
     libxml2-python-2.6.26-2.1.15.el5_8.6.x86_64.rpm
     libxml2-devel-2.6.26-2.1.15.el5_8.6.i386.rpm
     libxml2-devel-2.6.26-2.1.15.el5_8.6.x86_64.rpm
   i386
     libxml2-2.6.26-2.1.15.el5_8.6.i386.rpm
     libxml2-debuginfo-2.6.26-2.1.15.el5_8.6.i386.rpm
     libxml2-python-2.6.26-2.1.15.el5_8.6.i386.rpm
     libxml2-devel-2.6.26-2.1.15.el5_8.6.i386.rpm
SL6
   x86_64
     libxml2-2.7.6-8.el6_3.4.i686.rpm
     libxml2-2.7.6-8.el6_3.4.x86_64.rpm
     libxml2-debuginfo-2.7.6-8.el6_3.4.i686.rpm
     libxml2-debuginfo-2.7.6-8.el6_3.4.x86_64.rpm
     libxml2-python-2.7.6-8.el6_3.4.x86_64.rpm
     libxml2-devel-2.7.6-8.el6_3.4.i686.rpm
     libxml2-devel-2.7.6-8.el6_3.4.x86_64.rpm
     libxml2-static-2.7.6-8.el6_3.4.x86_64.rpm
   i386
     libxml2-2.7.6-8.el6_3.4.i686.rpm
     libxml2-debuginfo-2.7.6-8.el6_3.4.i686.rpm
     libxml2-python-2.7.6-8.el6_3.4.i686.rpm
     libxml2-devel-2.7.6-8.el6_3.4.i686.rpm
     libxml2-static-2.7.6-8.el6_3.4.i686.rpm

- Scientific Linux Development Team
 
CD: 2ms