Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: <updates <at> fedoraproject.org>
Subject: [SECURITY] Fedora 16 Update: wireshark-1.6.5-1.fc16
Newsgroups: gmane.linux.redhat.fedora.package.announce
Date: Sunday 22nd January 2012 22:52:56 UTC (over 4 years ago)
--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2012-0435
2012-01-14 03:35:26
--------------------------------------------------------------------------------

Name        : wireshark
Product     : Fedora 16
Version     : 1.6.5
Release     : 1.fc16
URL         : http://www.wireshark.org/
Summary     : Network traffic analyzer
Description :
Wireshark is a network traffic analyzer for Unix-ish operating systems.

This package lays base for libpcap, a packet capture and filtering
library, contains command-line utilities, contains plugins and
documentation for wireshark. A graphical user interface is packaged
separately to GTK+ package.

--------------------------------------------------------------------------------
Update Information:

The following vulnerabilities have been fixed.

wnpa-sec-2012-01 Laurent Butti discovered that Wireshark failed to properly
record sizes for many packet capture file formats.

wnpa-sec-2012-02 Wireshark could dereference a NULL pointer and crash

wnpa-sec-2012-03 The RLC dissector could overflow a buffer
--------------------------------------------------------------------------------
ChangeLog:

* Wed Jan 11 2012 Jan Safranek <[email protected]> - 1.6.5-1
- upgrade to 1.6.5
- see http://www.wireshark.org/docs/relnotes/wireshark-1.6.5.html
* Fri Dec  2 2011 Jan Safranek <[email protected]> - 1.6.4-1
- upgrade to 1.6.4
- see http://www.wireshark.org/docs/relnotes/wireshark-1.6.4.html
- build with c-ares and libpcap (#759305)
- fixed display of error message boxes on startup in gnome3 (#752559)
* Mon Nov 14 2011 Jan Safranek <[email protected]> - 1.6.3-2
- added dependency on shadow-utils (#753293)
- removed usermode support
* Wed Nov  2 2011 Jan Safranek <[email protected]> - 1.6.3-1
- upgrade to 1.6.3
- see http://www.wireshark.org/docs/relnotes/wireshark-1.6.3.html
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #773726 - CVE-2012-0041 wireshark: multiple file parser
vulnerabilities (wnpa-sec-2012-01)
        https://bugzilla.redhat.com/show_bug.cgi?id=773726
  [ 2 ] Bug #773728 - CVE-2012-0042 wireshark: NULL pointer vulnerabilities
(wnpa-sec-2012-02)
        https://bugzilla.redhat.com/show_bug.cgi?id=773728
  [ 3 ] Bug #773729 - CVE-2012-0043 wireshark: RLC dissector buffer
overflow (wnpa-sec-2012-03)
        https://bugzilla.redhat.com/show_bug.cgi?id=773729
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update wireshark' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on
the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
--------------------------------------------------------------------------------
_______________________________________________
package-announce mailing list
[email protected]
https://admin.fedoraproject.org/mailman/listinfo/package-announce
 
CD: 3ms