Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: <updates <at> fedoraproject.org>
Subject: [SECURITY] Fedora 11 Update: php-5.2.12-1.fc11
Newsgroups: gmane.linux.redhat.fedora.package.announce
Date: Monday 1st February 2010 01:09:42 UTC (over 6 years ago)
--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2010-0495
2010-01-14 00:54:15
--------------------------------------------------------------------------------

Name        : php
Product     : Fedora 11
Version     : 5.2.12
Release     : 1.fc11
URL         : http://www.php.net/
Summary     : PHP scripting language for creating dynamic web sites
Description :
PHP is an HTML-embedded scripting language. PHP attempts to make it
easy for developers to write dynamically generated webpages. PHP also
offers built-in database integration for several commercial and
non-commercial database management systems, so writing a
database-enabled webpage with PHP is fairly simple. The most common
use of PHP coding is probably as a replacement for CGI scripts.

The php package contains the module which adds support for the PHP
language to Apache HTTP Server.

--------------------------------------------------------------------------------
Update Information:

Update to the latest PHP 5.2 release which focuses on improving the
stability of
the PHP 5.2.x branch with over 60 bug fixes, some of which are security
related.
All users of PHP 5.2 are encouraged to upgrade to this release. See
http://www.php.net/releases/5_2_12.php
for more details.
--------------------------------------------------------------------------------
ChangeLog:

* Sun Jan 10 2010 Tim Jackson  5.2.12-1
- update to 5.2.12
- remove libedit patch (fixed upstream)
- fix encoding of EXTENSIONS file
* Tue Nov 17 2009 Tom "spot" Callaway  5.2.11-2
- link to libedit rather than readline to avoid licensing issues
* Fri Nov 13 2009 Tim Jackson  5.2.11-1
- update to 5.2.11
- add fix for upstream PHP bug #49098 (regression in 5.2.9+)
* Thu Jun 25 2009 Remi Collet  5.2.10-1
- update to 5.2.10
- add interbase sub-package
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #529213 - CVE-2009-3546 gd: insufficient input validation in
_gdGetColors()
        https://bugzilla.redhat.com/show_bug.cgi?id=529213
  [ 2 ] Bug #540459 - CVE-2009-4017 PHP: resource exhaustion attack via
upload requests with lots of files
        https://bugzilla.redhat.com/show_bug.cgi?id=540459
  [ 3 ] Bug #548516 - CVE-2009-4142 php: htmlspecialchars() insufficient
checking of input for multi-byte encodings
        https://bugzilla.redhat.com/show_bug.cgi?id=548516
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update php' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on
the
GPG keys used by the Fedora Project can be found at
http://fedoraproject.org/keys
--------------------------------------------------------------------------------
 
CD: 5ms