Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: <updates <at> fedoraproject.org>
Subject: [SECURITY] Fedora 18 Update: gksu-polkit-0.0.3-8.gitf8ce834c.fc18
Newsgroups: gmane.linux.redhat.fedora.package.announce
Date: Sunday 4th August 2013 00:08:08 UTC (over 3 years ago)
--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2013-13616
2013-07-25 22:55:49
--------------------------------------------------------------------------------

Name        : gksu-polkit
Product     : Fedora 18
Version     : 0.0.3
Release     : 8.gitf8ce834c.fc18
URL         : http://live.gnome.org/gksu
Summary     : Command line utility to run programs as root
Description :
This is a library and application used to ask the user for passwords to run
programs as root.

--------------------------------------------------------------------------------
Update Information:

* Recreate tarball from proper sources; previous package was shipping an
unknown code tarball.

* Add proper patching for CVE-2012-5617/CVE-2013-4161, the previous fix was
creating a patch file and not patching the code.

* Use proper bus name in service file to fix service timeout.
--------------------------------------------------------------------------------
ChangeLog:

* Sun Jul 21 2013 Simone Caronni  -
0.0.3-8.gitf8ce834c
- Update to git snapshot, add script to recreate tarball.
- Fix Patch1, was creating a patch file and not patching files.
- Add fix to service file from  Jan Pokorný (#975541).
* Tue Jun 11 2013 Simone Caronni  - 0.0.3-7
- Fix systemd service file (#948613).
- SPEC file formatting.
* Wed Feb 13 2013 Fedora Release Engineering
 - 0.0.3-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #987561 - CVE-2013-4161 gksu-polkit: improper patching of
CVE-2012-5617
        https://bugzilla.redhat.com/show_bug.cgi?id=987561
  [ 2 ] Bug #883162 - CVE-2012-5617 gksu-polkit: privilege escalation due
to improper authentication settings in policykit configuration file
        https://bugzilla.redhat.com/show_bug.cgi?id=883162
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update gksu-polkit' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on
the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
--------------------------------------------------------------------------------
_______________________________________________
package-announce mailing list
[email protected]
https://admin.fedoraproject.org/mailman/listinfo/package-announce
 
CD: 3ms