Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: <updates <at> fedoraproject.org>
Subject: [SECURITY] Fedora 17 Update: rubygem-actionpack-3.0.11-9.fc17
Newsgroups: gmane.linux.redhat.fedora.package.announce
Date: Saturday 30th March 2013 21:27:37 UTC (over 3 years ago)
--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2013-4199
2013-03-21 23:11:47
--------------------------------------------------------------------------------

Name        : rubygem-actionpack
Product     : Fedora 17
Version     : 3.0.11
Release     : 9.fc17
URL         : http://www.rubyonrails.org
Summary     : Web-flow and rendering framework putting the VC in MVC
Description :
Eases web-request routing, handling, and response as a half-way front,
half-way page controller. Implemented with specific emphasis on enabling
easy
unit/integration testing that doesn't require a browser.

--------------------------------------------------------------------------------
Update Information:

Fix for CVE-2013-1855 and CVE-2013-1857.
--------------------------------------------------------------------------------
ChangeLog:

* Thu Mar 21 2013 Vít Ondruch  - 1:3.0.11-9
- Fix for CVE-2013-1855 and CVE-2013-1857.
* Thu Jan 10 2013 Vít Ondruch  - 1:3.0.11-8
- Fix for CVE-2013-0155.
* Mon Aug 13 2012 Vít Ondruch  - 1:3.0.11-7
- Fixes for CVE-2012-3463, CVE-2012-3464 and CVE-2012-3465.
* Tue Jul 31 2012 Vít Ondruch  - 1:3.0.11-6
- Fix for CVE-2012-3424.
* Mon Jun 18 2012 Vít Ondruch  - 1:3.0.11-5
- Fix for CVE-2012-2694.
* Mon Jun  4 2012 Vít Ondruch  - 1:3.0.11-4
- Fix for CVE-2012-2660.
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #921331 - CVE-2013-1855 rubygem-actionpack: css_sanitization:
XSS vulnerability in sanitize_css
        https://bugzilla.redhat.com/show_bug.cgi?id=921331
  [ 2 ] Bug #921335 - CVE-2013-1857 rubygem-actionpack: sanitize_protocol:
XSS Vulnerability in the  helper of Ruby on Rails
        https://bugzilla.redhat.com/show_bug.cgi?id=921335
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update rubygem-actionpack' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on
the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
--------------------------------------------------------------------------------
_______________________________________________
package-announce mailing list
[email protected]
https://admin.fedoraproject.org/mailman/listinfo/package-announce
 
CD: 2ms