Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Errata Announcements for Oracle Linux <el-errata <at> oss.oracle.com>
Subject: ELSA-2012-1207 Moderate: Oracle Linux 5 glibc security and bug fix update
Newsgroups: gmane.linux.oracle.el-errata
Date: Tuesday 28th August 2012 01:37:16 UTC (over 4 years ago)
Oracle Linux Security Advisory ELSA-2012-1207

https://rhn.redhat.com/errata/RHSA-2012-1207.html

The following updated rpms for Oracle Linux 5 have been uploaded to the 
Unbreakable Linux Network:

i386:
glibc-2.5-81.el5_8.7.i386.rpm
glibc-2.5-81.el5_8.7.i686.rpm
glibc-common-2.5-81.el5_8.7.i386.rpm
glibc-devel-2.5-81.el5_8.7.i386.rpm
glibc-headers-2.5-81.el5_8.7.i386.rpm
glibc-utils-2.5-81.el5_8.7.i386.rpm
nscd-2.5-81.el5_8.7.i386.rpm

x86_64:
glibc-2.5-81.el5_8.7.i686.rpm
glibc-2.5-81.el5_8.7.x86_64.rpm
glibc-common-2.5-81.el5_8.7.x86_64.rpm
glibc-devel-2.5-81.el5_8.7.i386.rpm
glibc-devel-2.5-81.el5_8.7.x86_64.rpm
glibc-headers-2.5-81.el5_8.7.x86_64.rpm
glibc-utils-2.5-81.el5_8.7.x86_64.rpm
nscd-2.5-81.el5_8.7.x86_64.rpm

ia64:
glibc-2.5-81.el5_8.7.i686.rpm
glibc-2.5-81.el5_8.7.ia64.rpm
glibc-common-2.5-81.el5_8.7.ia64.rpm
glibc-devel-2.5-81.el5_8.7.ia64.rpm
glibc-headers-2.5-81.el5_8.7.ia64.rpm
glibc-utils-2.5-81.el5_8.7.ia64.rpm
nscd-2.5-81.el5_8.7.ia64.rpm


SRPMS:
http://oss.oracle.com/ol5/SRPMS-updates/glibc-2.5-81.el5_8.7.src.rpm



Description of changes:

[2.5-81.el5_8.7]
- Fix out of bounds array access in strto* exposed by 847929 patch.

[2.5-81.el5_8.6]
- Fix integer overflow leading to buffer overflow in strto* (#847929)

[2.5-81.el5_8.5]
- Do not use PT_IEEE_IP ptrace calls (#839411)
- Update ULPs (#839411)
- Fix various transcendentals in non-default rounding modes (#839411)
 
CD: 3ms