Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Errata Announcements for Oracle Linux <el-errata <at> oss.oracle.com>
Subject: ELSA-2013-1764 Critical: Oracle Linux 6 ruby security update
Newsgroups: gmane.linux.oracle.el-errata
Date: Wednesday 27th November 2013 17:53:00 UTC (over 3 years ago)
Oracle Linux Security Advisory ELSA-2013-1764

https://rhn.redhat.com/errata/RHSA-2013-1764.html

The following updated rpms for Oracle Linux 6 have been uploaded to the 
Unbreakable Linux Network:

i386:
ruby-1.8.7.352-13.el6.i686.rpm
ruby-devel-1.8.7.352-13.el6.i686.rpm
ruby-docs-1.8.7.352-13.el6.i686.rpm
ruby-irb-1.8.7.352-13.el6.i686.rpm
ruby-libs-1.8.7.352-13.el6.i686.rpm
ruby-rdoc-1.8.7.352-13.el6.i686.rpm
ruby-ri-1.8.7.352-13.el6.i686.rpm
ruby-static-1.8.7.352-13.el6.i686.rpm
ruby-tcltk-1.8.7.352-13.el6.i686.rpm

x86_64:
ruby-1.8.7.352-13.el6.x86_64.rpm
ruby-devel-1.8.7.352-13.el6.i686.rpm
ruby-devel-1.8.7.352-13.el6.x86_64.rpm
ruby-docs-1.8.7.352-13.el6.x86_64.rpm
ruby-irb-1.8.7.352-13.el6.x86_64.rpm
ruby-libs-1.8.7.352-13.el6.i686.rpm
ruby-libs-1.8.7.352-13.el6.x86_64.rpm
ruby-rdoc-1.8.7.352-13.el6.x86_64.rpm
ruby-ri-1.8.7.352-13.el6.x86_64.rpm
ruby-static-1.8.7.352-13.el6.x86_64.rpm
ruby-tcltk-1.8.7.352-13.el6.x86_64.rpm


SRPMS:
http://oss.oracle.com/ol6/SRPMS-updates/ruby-1.8.7.352-13.el6.src.rpm



Description of changes:

[1.8.7.352-13]
- Workaround build issues against OpenSSL with enabled ECC curves.
- Make DRb compatible with OpenSSL 1.0.1.
   * ruby-1.9.3-p222-generate-1024-bits-RSA-key-instead-of-512-bits.patch
- Fix CVE-2013-4164 Heap Overflow in Floating Point Parsing
   * 
ruby-1.9.3-p484-CVE-2013-4164-ignore-too-long-fraction-part-which-does-not-affect-the-result.patch
   - Resolves: rhbz#1033500
 
CD: 3ms