Subject: [PATCH v2 0/7] uprobes/tracing: uretprobes
Date: Tuesday 9th April 2013 19:32:01 UTC (over 3 years ago)
On 04/09, Steven Rostedt wrote: > > On Tue, 2013-04-09 at 16:50 +0200, Oleg Nesterov wrote: > > On 04/08, Steven Rostedt wrote: > > > OK, will do. > > > > Or. Instead of enum we can use "bool is_return". So, instead of > > > > if (is_ret_probe(tu)) > > size = SIZEOF_TRACE_ENTRY(UPROBE_ENTRY_RETPROBE); > > else > > size = SIZEOF_TRACE_ENTRY(UPROBE_ENTRY_NORMAL); > > > > we can do > > > > size = SIZEOF_TRACE_ENTRY(is_ret_probe(tu)); > > > > What do you like more? > > Which ever is easier ;-) > > I just hated the magic "1" and "2". As long as I (or any reviewer) does > not need to go searching for numbers, and can easily figure out what is > going on by looking at the code at hand, I'm happy. > > Both the above satisfy that requirement. > > Your "is_ret_probe(tu)" may have the added bonus of being less error > prone. OK, please see v2. Change SIZEOF_TRACE_ENTRY/DATAOF_TRACE_ENTRY to accept "bool is_return" rather than "int nr". Srikar, I preserved your acks, hopefully this is fine. But 4/7 still doesn't have your ack. Oleg.