Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Steven Rostedt <rostedt <at> goodmis.org>
Subject: Re: [RFC][PATCH] tracing: Remove useless 4 bytes of padding from every event
Newsgroups: gmane.linux.kernel
Date: Wednesday 16th May 2012 20:00:04 UTC (over 4 years ago)
On Wed, 2012-05-16 at 12:33 -0700, Linus Torvalds wrote:

> F16 and F17 seem to have powertop-1.98, which I assume is the new
> world order already. But maybe I assume incorrectly.

Seriously though. What's your take on changing the kernel that will
break an older distro. Obviously, this change is too early to apply. But
because an old distro has one app that will break if we make a change in
the kernel, is that enough to keep that change out?

Lets say we are at F23, and F18+ have the new powertop tools. Lets even
go to say that F16 and F17 have updated their powertop to powertop v2.

Because someone may be running a F17 without updates, which has powertop
that will break if they update their kernel, rational to keeping that
change out?

I want to know if this change will ever go in. Otherwise, I have to make
workarounds for it. I have no problem with that, as I will be adding
workarounds anyway, but this will continue to punish the tools that use
the non-workaround methods even though they don't break with the change.

Now if you say that it's OK to break and old distro if the affected
tools in the new distros work. What's the timeframe of that? One year?

-- Steve
 
CD: 4ms