* Linus Torvalds wrote:
> Seriously, I don't understand why you don't just use the
> obvious name. The data structure is named "static_key". The
> things that change it are named "static_key_inc()" or
> something. So a name like "static_key_true()" is simply
> *better*, isn't it?
Yes, you are right, in hindsight it's indeed obviously and
trivially better :-/
> It's not just about less confusion, it's actually about just
> having consistent naming.
Okay. I sent out the slightly reworked patch that gets rid of
this confusion and makes it all consistent.