Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: =?UTF-8?B?UGV0dGVyaSBSw6R0eQ==?= <betelgeuse-aBrp7R+bbdUdnm+yROfE0A <at> public.gmane.org>
Subject: Removing stable keywords from blackdown-jdk|jre
Newsgroups: gmane.linux.gentoo.java
Date: Thursday 21st June 2007 22:36:08 UTC (over 10 years ago)
Any objections to removing stable keywords from blackdown-jdk and
blackdown-jre. Reasoning being that's it's based on 1.4.2.03 sources and
as such has all the security vulnerabilies discovered since then and
upstream is dead. Here is one example:
https://bugs.gentoo.org/show_bug.cgi?id=182824

For ebuilds needing =virtual/jdk-1.4* the stable alternative will be
ibm-jdk-bin:1.4 for amd64 and sun-jdk:1.4 x86. Yes they are both fetch
restricted but there should only be a couple of these packages left any
way. I will try to compile a list.

Here is a list of ebuilds that need switching from 1.5 to something else:

dev-db/xindice-1.0-r4
        ~x86 ~ppc
dev-java/adaptx-0.9.13_p20041105-r3
        amd64 ppc ppc64 x86
dev-java/backport-util-concurrent-1.1.01-r1
        amd64 ppc x86
dev-java/fop-0.20.5-r7
        amd64 ~ia64 ~ppc64 x86
dev-java/gnu-jaxp-1.3-r1
        amd64 ~ppc ppc64 x86
dev-java/openjms-0.7.6.1-r2
        ~amd64 ~x86
dev-tinyos/tos-getenv-1.1.15-r1
        ~x86 ~amd64
dev-tinyos/tos-scripts-1.1.15-r1
        ~x86 ~amd64
games-strategy/freecol-0.6.1
        ~amd64 ~x86
media-sound/jmax-4.1.0
        -amd64 ~ppc -sparc x86
sci-geosciences/mapserver-4.10.0-r1
        ~x86

So for stable amd64 we have:
dev-java/adaptx-0.9.13_p20041105-r3
        amd64 ppc ppc64 x86
dev-java/backport-util-concurrent-1.1.01-r1
        amd64 ppc x86
dev-java/fop-0.20.5-r7
        amd64 ~ia64 ~ppc64 x86
dev-java/gnu-jaxp-1.3-r1
        amd64 ~ppc ppc64 x86

Shouldn't be too hard to go make these go away too.
 
CD: 3ms