Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Johannes Stezenbach <js <at> linuxtv.org>
Subject: Re: [PATCH] Re: [PATCH] Multi protocol support (stage #1)
Newsgroups: gmane.linux.drivers.dvb
Date: Thursday 25th May 2006 12:32:28 UTC (over 11 years ago)
On Thu, May 25, 2006, [email protected] wrote:
> Arrrrgh, twice the same error :(
> 
> [snip]
> >>If the transmitter broadcasts MIS, I have to set a stream_id
> >>(otherwise I'd get a garbage mix of multiple TS, right?).
> >>Do I then have to set the sismis to DVBFE_SISMIS_MULTIPLE
> >>(because it's MIS) or DVBFE_SISMIS_SINGLE (because I want
> >>to filter out just one of them)?
> [snip]
> >sismis and stream_id are only used in backward compatible mode.
> >In the mis mode both hp and lp streams are received, whereas in sis mode
> >stream_id is used to select hp or lp stream.
> [snip]
> 
> sismis and stream_id are only used in backward compatible mode.
> In the sis mode there is only one stream to receive, whereas in mis mode
> stream_id is used to select hp or lp stream.
> 
> Sorry for any confusion.

I was just about to complain ;-)


My question was regarding the semantics of and/or naming
of the sismis flag. I'm sorry for the unclear wording,
I'll try again:

- SIS/MIS is part of baseband signalling (BBHEADER): My understanding
  is that the demod can receive the BBHEADER without prior knowledge
  if it is SIS or MIS. Thus you don't have to tell it about that.

- However, if it is MIS: You have to enable the stream-id filter in
  the demod and set a stream_id (ISI), otherwise you'd get either
  garbage (two or more TS mixed together) or nothing (depending
  on how demod hw/fw handles this error)

- Similarly, if it is SIS, you have to disable the stream-id
  filter because you don't know the stream_id to filter on
  (unless the demod hw/fw does disregard the filter anyway if
  it sees the stream is SIS)

Consequently, I would rename "enum dvbfe_sismis_flag sismis"
to a boolean "enable_stream_id_filter". Because this
type and name would reflect what it actually does.

So, not a functional change, the drivers would use
enable_stream_id_filter in exactly the same way as
sismis, but it is easier to understand how to use
the API.

Provided that my understanding of the matter is correct, of course.


Johannes

_______________________________________________
linux-dvb mailing list
[email protected]
http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
 
CD: 4ms