Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Axel Beckert <abe <at> debian.org>
Subject: Bug#721364: perl: Missing Pre-Depends/Breaks/Conflicts wrt. libscalar-list-utils-perl and the Perl 5.18 transition
Newsgroups: gmane.linux.debian.devel.bugs.rc
Date: Friday 30th August 2013 18:28:00 UTC (over 3 years ago)
Package: perl
Version: 5.18.1-2
Severity: serious

Hi,

as discussed with Dom, Niko and Jonas on #debian-perl:

The Perl 5.18 upgrade on one of my boxes (kfreebsd-i386, cdebconf,
tons of devel and desktop packages installed) went bad because
libscalar-list-utils-perl should have been upgraded earlier. (Niko
Tyni mentioned that this is probablu there since 1.23_03 -- which
dropped the fallback to pure perl versions.)

I haven't all the output anymore, but this was basically the caused
deadlock:

On kfreebsd-i386 Sid after the Perl 5.18 upgrade:

~ # dpkg --configure --pending
Setting up libxml-libxml-perl (2.0010+dfsg-1+b1) ...
Perl API version v5.14.0 of List::Util does not match v5.18.0 at
/usr/share/perl/5.18/XSLoader.pm line 92.
Compilation failed in require at /usr/lib/perl5/Scalar/Util.pm line 11.
Compilation failed in require at /usr/share/perl/5.18/File/Temp.pm line
151.
BEGIN failed--compilation aborted at /usr/share/perl/5.18/File/Temp.pm line
151.
Compilation failed in require at /usr/bin/update-perl-sax-parsers line 20.
BEGIN failed--compilation aborted at /usr/bin/update-perl-sax-parsers line
20.
dpkg: error processing libxml-libxml-perl (--configure):
 subprocess installed post-installation script returned error exit status
255
Setting up man-db (2.6.5-2) ...
Can't load '/usr/lib/perl5/auto/List/Util/Util.so' for module List::Util:
/usr/lib/perl5/auto/List/Util/Util.so: undefined symbol: Perl_gv_init at
/usr/share/perl/5.18/XSLoader.pm line 68.
 at /usr/lib/perl5/List/Util.pm line 21.
Compilation failed in require at /usr/lib/perl5/Scalar/Util.pm line 11.
Compilation failed in require at /usr/lib/perl/5.18/Hash/Util.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl/5.18/Hash/Util.pm line
9.
Compilation failed in require at /usr/share/perl/5.18/fields.pm line 122.
Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Db.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Db.pm line 7.
Compilation failed in require at /usr/share/debconf/frontend line 6.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 6.
dpkg: error processing man-db (--configure):
 subprocess installed post-installation script returned error exit status
255
dpkg: dependency problems prevent configuration of xacobeo:
 xacobeo depends on libxml-libxml-perl; however:
  Package libxml-libxml-perl is not configured yet.

dpkg: error processing xacobeo (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxml-libxslt-perl:
 libxml-libxslt-perl depends on libxml-libxml-perl; however:
  Package libxml-libxml-perl is not configured yet.

dpkg: error processing libxml-libxslt-perl (--configure):
 dependency problems - leaving unconfigured
Setting up gnumeric (1.12.6-1) ...
Can't load '/usr/lib/perl5/auto/List/Util/Util.so' for module List::Util:
/usr/lib/perl5/auto/List/Util/Util.so: undefined symbol: Perl_gv_init at
/usr/share/perl/5.18/XSLoader.pm line 68.
 at /usr/lib/perl5/List/Util.pm line 21.
Compilation failed in require at /usr/lib/perl5/Scalar/Util.pm line 11.
Compilation failed in require at /usr/lib/perl/5.18/Hash/Util.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl/5.18/Hash/Util.pm line
9.
Compilation failed in require at /usr/share/perl/5.18/fields.pm line 122.
Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Db.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Db.pm line 7.
Compilation failed in require at /usr/share/debconf/frontend line 6.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 6.
dpkg: error processing man-db (--configure):
 subprocess installed post-installation script returned error exit status
255
dpkg: dependency problems prevent configuration of xacobeo:
 xacobeo depends on libxml-libxml-perl; however:
  Package libxml-libxml-perl is not configured yet.

dpkg: error processing xacobeo (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxml-libxslt-perl:
 libxml-libxslt-perl depends on libxml-libxml-perl; however:
  Package libxml-libxml-perl is not configured yet.

dpkg: error processing libxml-libxslt-perl (--configure):
 dependency problems - leaving unconfigured
Setting up gnumeric (1.12.6-1) ...
Can't load '/usr/lib/perl5/auto/List/Util/Util.so' for module List::Util:
/usr/lib/perl5/auto/List/Util/Util.so: undefined symbol: Perl_gv_init at
/usr/share/perl/5.18/XSLoader.pm line 68.
 at /usr/lib/perl5/List/Util.pm line 21.
Compilation failed in require at /usr/lib/perl5/Scalar/Util.pm line 11.
Compilation failed in require at /usr/lib/perl/5.18/Hash/Util.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl/5.18/Hash/Util.pm line
9.
Compilation failed in require at /usr/share/perl/5.18/fields.pm line 122.
Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Db.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Db.pm line 7.
Compilation failed in require at /usr/share/debconf/frontend line 6.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 6.
dpkg: error processing gnumeric (--configure):
 subprocess installed post-installation script returned error exit status
255
dpkg: dependency problems prevent configuration of gnumeric-plugins-extra:
 gnumeric-plugins-extra depends on gnumeric (= 1.12.6-1); however:
  Package gnumeric is not configured yet.

dpkg: error processing gnumeric-plugins-extra (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libxml-libxml-perl
 man-db
 xacobeo
 libxml-libxslt-perl
 gnumeric
 gnumeric-plugins-extra

I've solved this by manually installing the libscalar-list-utils-perl
version which was built against Perl 5.18. The previously installed
one was the one built against Perl 5.14 while perl and perl-modules
itselves were already at the 5.18.1-2 version.

-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (600, 'testing'), (110, 'experimental')
Architecture: kfreebsd-i386 (i386)

Kernel: kFreeBSD 9.1-1-686
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages perl depends on:
ii  libbz2-1.0    1.0.6-5
ii  libc0.1       2.17-92
ii  libdb5.1      5.1.29-7
ii  libgdbm3      1.8.3-12
ii  perl-base     5.18.1-2
ii  perl-modules  5.18.1-2
ii  zlib1g        1:1.2.8.dfsg-1

Versions of packages perl recommends:
ii  netbase  5.1

Versions of packages perl suggests:
ii  libterm-readline-gnu-perl   1.20-2+b2
ii  libterm-readline-perl-perl  1.0303-1
ii  make                        3.82-1
ii  perl-doc                    5.18.1-2

-- no debconf information

-- debsums errors found:
Perl API version v5.14.0 of File::FnMatch does not match v5.18.0 at
/usr/lib/perl/5.18/DynaLoader.pm line 207.
Compilation failed in require at /usr/bin/debsums line 23.
BEGIN failed--compilation aborted at /usr/bin/debsums line 23.
 
CD: 3ms