Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Christoph Egger <christoph <at> debian.org>
Subject: Bug#673165: mapserver: FTBFS[armel,kfreebsd-i386,mips]: configure: error: Could not find gd.h or libgd.a/libgd.so in /usr.
Newsgroups: gmane.linux.debian.devel.bugs.rc
Date: Wednesday 16th May 2012 14:54:58 UTC (over 4 years ago)
Package: src:mapserver
Version: 6.0.1-3
Severity: serious
Tags: sid wheezy
Justification: fails to build from source (but built successfully in the
past)

Hi!

Your package failed to build on the buildds:

checking for jpeglib.h... yes
        using libjpeg from system libs.
configure: checking where libXpm is installed...
checking for XpmFreeXpmImage in -lXpm... yes
        using libXpm from system libs.
configure: checking where libiconv is installed...
checking for iconv_open in -lc... yes
checking for libiconv_open in -liconv... no
checking for iconv_open in -liconv... no
        using libiconv from system libs.
        libiconv found. Enabling internationalization (-DUSE_ICONV)
configure: checking for GD 2.0.28 or higher...
configure: error: Could not find gd.h or libgd.a/libgd.so in /usr.  Make
sure GD 2.0.28 or higher is compiled before calling configure. You may also
get this error if you didn't specify the appropriate location for one of
GD's dependencies (freetype, libpng, libjpeg or libiconv).
checking for gdImageCreatePaletteFromTrueColor in -lgd... yes
make: *** [configure-stamp] Error 1

Full build log at
https://buildd.debian.org/status/fetch.php?pkg=mapserver&arch=kfreebsd-i386&ver=6.0.1-3%2Bb1&stamp=1337043503

Regards

    Christoph

-- 
9FED 5C6C E206 B70A 5857  70CA 9655 22B9 D49A E731
Debian Developer | Lisp Hacker | CaCert Assurer
 
CD: 22ms