Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Damyan Ivanov <dmn <at> debian.org>
Subject: Bug#542562: libgnome2-print-perl: uses libgnomeprint which is scheduled for removal
Newsgroups: gmane.linux.debian.devel.bugs.general
Date: Thursday 20th August 2009 09:42:24 UTC (over 7 years ago)
-=| [email protected], Thu, Aug 20, 2009 at 10:54:57AM +0200 |=-
> Package: libgnome2-print-perl
> Version: 1.000-1
> Severity: important
> 
> libgnome2-print-perl currently still uses libgnomeprint. However,
> libgnomeprint and libgnomeprintui are going to be soon deprecated
> upstream. The GtkPrint replacement (built in GTK+ itself) has been
> available for 3 years.
> 
> I???d like to remove libgnomeprint packages before the squeeze
> release. This can only be done by getting rid of as much as possible
> of the reverse dependencies.
> 
> Note that some of these packages already include GtkPrint support,
> but you have to select it at compile time. Otherwise, please consider
> porting to the much more modern Cairo/GtkPrint API.

There is no mention of GtkPrint in the sources, so I guess 
Gnome2::Print is not ready to use that. It appears GtkPrint is 
available via Gtk2 module (libgtk2-perl).

> As for bindings, they don???t have any reverse dependencies except
> for the Python ones, so they should simply be removed ASAP.

Shall we remove libgnome2-print-perl from the archive? The popcon 
rating doesn't seem particularly high:
http://qa.debian.org/popcon.php?package=libgnome2-print-perl

-- 
dam
 
CD: 42ms