Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Daniel Schepler <schepler <at> math.unipd.it>
Subject: Bug#392775: libtest-www-mechanize-perl: FTBFS: Missing Build-Depends and other test failures
Newsgroups: gmane.linux.debian.devel.bugs.general
Date: Friday 13th October 2006 12:43:59 UTC (over 10 years ago)
Package: libtest-www-mechanize-perl
Version: 1.12-1
Severity: serious

From my pbuilder build log:

...
/usr/bin/make test
make[1]: Entering directory `/tmp/buildd/libtest-www-mechanize-perl-1.12'
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e"
"test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00load................# Testing Test::WWW::Mechanize 1.12, Perl 5.008008,
/usr/bin/perl
ok
t/content_contains......Use of uninitialized value in socket at
/usr/share/perl5/HTTP/Server/Simple.pm line 573,  line 16.

#   Failed test 'Finds the contains'
#   in t/content_contains.t at line 31.
...
Failed Test            Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
t/content_contains.t                  5    2  40.00%  4-5
t/content_lacks.t                     5    1  20.00%  5
t/follow_link_ok.t                    6    1  16.67%  4
t/followable_links.t      1   256     4    1  25.00%  4
t/get_ok.t                           11    4  36.36%  4-5 7 9
t/has_tag.t                           7    2  28.57%  4 6
t/link_content.t                      9    2  22.22%  6 9
t/link_status.t                       8    2  25.00%  6 8
t/links_ok.t                          8    3  37.50%  5-7
t/page_links_content.t                9    2  22.22%  6 9
t/page_links_ok.t                     5    1  20.00%  5
2 tests skipped.
Failed 11/17 test scripts, 35.29% okay. 21/104 subtests failed, 79.81%
okay.
make[1]: *** [test_dynamic] Error 255
make[1]: Leaving directory `/tmp/buildd/libtest-www-mechanize-perl-1.12'
make: *** [install-stamp] Error 2

Adding netbase to the Build-Depends (most likely needed for /etc/services
and/or /etc/protocols) fixes most of these test failures, but not all:

...
t/link_content..........NOK 6
#   Failed test 'Handles link content not found'
#   in t/link_content.t at line 48.
# STDOUT is:
# ok 1 - Checking all page link content failures
#
# not:
# not ok 1 - Checking all page link content failures
#
# as expected
# STDERR is:
#
# not:
# (?-xism:#\s+Failed\ test.*?\n?.*?t\/link_content\.t at line 47.*\n?)
# # goodlinks.html
#
# # badlinks.html
#
# # goodlinks.html
#
# as expected
... [the other failures look similar]
Failed Test       Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
t/link_content.t                 9    2  22.22%  6 9
t/page_links_ok.t                5    1  20.00%  5
2 tests skipped.
Failed 2/17 test scripts, 88.24% okay. 3/104 subtests failed, 97.12% okay.
make[1]: *** [test_dynamic] Error 255
make[1]: Leaving directory `/tmp/buildd/libtest-www-mechanize-perl-1.12'
make: *** [install-stamp] Error 2

-- 
Daniel Schepler
 
CD: 3ms