Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Takashi Iwai <tiwai <at> suse.de>
Subject: Re: model needed for Clevo P150HM (Realtek ALC892)
Newsgroups: gmane.linux.alsa.devel
Date: Friday 1st July 2011 05:21:34 UTC (over 6 years ago)
At Thu, 30 Jun 2011 22:16:04 +0200,
Julian Sikorski wrote:
> 
> W dniu 30.06.2011 21:28, Takashi Iwai pisze:
> > At Thu, 30 Jun 2011 20:09:49 +0200,
> > Julian Sikorski wrote:
> >>
> >> $ dmesg | grep XXX
> >> [   14.813013] XXX alc662_auto_fill_dac_nids called
> >> [   14.813015] XXX line_outs=1, 14/0/0
> >> [   14.813016] XXX hp_outs=1, 1b/0/0
> >> [   14.813018] XXX spk_outs=0, 0/0/0
> >> [   14.813186] XXX filled dacs: 2/0/0/0/0, hp 0, ext 0/0/0
> >> [   14.813187] XXX swap primary out to HP
> >> [   14.813188] XXX spk=14
> >> [   14.813190] XXX line=1b
> >> [   14.813191] XXX alc662_auto_fill_dac_nids called
> >> [   14.813192] XXX line_outs=1, 1b/0/0
> >> [   14.813194] XXX hp_outs=0, 0/0/0
> >> [   14.813195] XXX spk_outs=1, 14/0/0
> >> [   14.813311] XXX filled dacs: 2/0/0/0/0, hp 0, ext 0/0/0
> >> [   14.813560] XXX added multi-io pin 1a, dac 3
> >> [   14.813814] XXX added multi-io pin 18, dac 4
> >> [   14.813818] XXX create mixer ch 0 pin 1b dac 2 mix c
> >> [   14.813821] XXX create mixer ch 1 pin 1a dac 3 mix d
> >> [   14.813825] XXX create mixer ch 2 pin 18 dac 4 mix e
> > 
> > How about the fix below?
> > 
> > 
> > Takashi
> 
> It works, thanks! In more detail, the Speaker/Headphone situation is
> back to 2.6.38 state - you can regulate them independently, but muting
> one mutes the other. LFE/Center and Surround keep working correctly too.
> The new output of alsa-info.sh:
> http://www.alsa-project.org/db/?f=45bc0df9747371b348bde6c4aa508b2ba44aff47

Right, it's because ALC892 has no mute-control in pin widgets but
only in the mixer widget.  And HP and speaker paths share the same
mixer, thus it's impossible to mute independently.

> So it seems that the only things remaining are the SPDIF/rear channel
> jack and the coupled muting issue.

It's a BIOS bug.  It doesn't tell SPDIF is available.
Ditto for the 4th stereo out.  No pin is exposed by BIOS.


thanks,

Takashi
 
CD: 4ms