Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Olaf Dietsche <olaf+list.linux-acpi <at> olafdietsche.de>
Subject: [2.6.22-rc3][ACPI?] Resume from s2r doesn't work.
Newsgroups: gmane.linux.acpi.devel
Date: Friday 1st June 2007 20:27:49 UTC (over 10 years ago)
Hi,

resume from suspend to ram doesn't work for my laptop and never
has. So, this is not a regression.

Hibernate (aka suspend to disk) works, however.

When I resume, everything seems to come up (fan becomes busy, disk and
dvd spin up for a short time), but the machine is not responding to
anything - neither keyboard, mouse nor ping from another machine. The
laptop is effectively dead and only a power cycle helps.

I've tried a minimal config and init=/bin/bash as well, but the result
is the same.

When I skip acpi_enter_sleep_state():

diff -urN -X b/Documentation/dontdiff a/drivers/acpi/hardware/hwsleep.c
b/drivers/acpi/hardware/hwsleep.c
--- a/drivers/acpi/hardware/hwsleep.c	2007-05-27 23:47:25.000000000 +0200
+++ b/drivers/acpi/hardware/hwsleep.c	2007-06-01 10:45:46.000000000 +0200
@@ -268,6 +268,7 @@
 	u32 in_value;
 	acpi_status status;
 
+	return_ACPI_STATUS(AE_OK);
 	ACPI_FUNCTION_TRACE(acpi_enter_sleep_state);
 
 	if ((acpi_gbl_sleep_type_a > ACPI_SLEEP_TYPE_MAX) ||

my laptop suspends and immediately resumes without problems. So it
seems, that the drivers suspend and resume correctly.

Attached is my minimal config, /proc/cpuinfo, lspci -vvv and dmesg
output.  How can I go on from here? Anything I can test, patch or
debug?

Regards, Olaf.
 
CD: 5ms