Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Vladimir Alexiev <vladimir <at> sirma.bg>
Subject: [BUG] org-html.el: internal links don't work unless CUSTOM_ID is used
Newsgroups: gmane.emacs.orgmode
Date: Sunday 30th January 2011 14:48:00 UTC (over 5 years ago)
Internal links do not work in HTML export unless CUSTOM_ID is used.

I have tried with [[id:]] and [[*Heading]] links.
It makes the link like this:
  
It makes the anchor like this:
  

...

and if the entry has ID (id: link is used) then also
Unfortunately h2.id doesn't create an anchor, and even for id: links it uses , which doesn't work. I wondered how links in WORK work, so I checked, e.g. http://orgmode.org/worg/org-contrib/babel/intro.html The link is denoted like this [[#source-code-execution][here]] and the target like this: * Source Code Execution :PROPERTIES: :CUSTOM_ID: source-code-execution :END: Indeed the Org manual advises: The most important case is a link like `[[#my-custom-id]]' which will link to the entry with the `CUSTOM_ID' property `my-custom-id'. Such custom IDs are very good for HTML export (*note HTML export::) where they produce pretty section links. But it would be very tedious to add CUSTOM_ID to every target, and the manual also hints to it: You are responsible yourself to make sure these custom IDs are unique Having to go out and make a target interrupts one's flow. It's much faster to type "[[*He" and use completion to create the link. That's why I've marked this "BUG" and not "Enhancement". _______________________________________________ Emacs-orgmode mailing list Please use `Reply All' to send replies to the list. [email protected] http://lists.gnu.org/mailman/listinfo/emacs-orgmode
 
CD: 3ms