Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Greg Troxel <gdt <at> ir.bbn.com>
Subject: excessive blank lines in archives
Newsgroups: gmane.emacs.orgmode
Date: Sunday 19th December 2010 01:38:21 UTC (over 6 years ago)
I've been noticed extra lines in archive files.  I did a controlled test
by creating a simple foo.org:

----------------------------------------
* test item 1
  this is a test item
* test item 2
  this is a test item
----------------------------------------

I then moved to the first * and did C-x $ to archive.  That got me an
archive file with an extra blank line near the top, and two blank lines
at the end.  Moving to the second * got me three blank lines at the end
of the archive file.   I expect only one blank line between the mode:
line and "Archived entries", and I don't expect any extra blank lines
beyond the items added.  (If there is a blank line added between entries
when there wasn't one, that seems ok, but they accumulate on the end.)

My setup is recent git master, emacs 23.2, NetBSD 5.1, i386.  I wonder
if I am confused, I have misconfigured org, or if there is a bug?

My foo.org_archive after two archive operations (did not exist before):

----------------------------------------
#    -*- mode: org -*-


Archived entries from file /home/gdt/ORG/foo.org
* test item 1
  :PROPERTIES:
  :ARCHIVE_TIME: 2010-12-18 Sat 20:32
  :ARCHIVE_FILE: ~/ORG/foo.org
  :ARCHIVE_CATEGORY: foo
  :END:
  this is a test item
* test item 2
  :PROPERTIES:
  :ARCHIVE_TIME: 2010-12-18 Sat 20:32
  :ARCHIVE_FILE: ~/ORG/foo.org
  :ARCHIVE_CATEGORY: foo
  :END:
  this is a test item



----------------------------------------
 
CD: 4ms