Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Nicolas Goaziou <n.goaziou <at> gmail.com>
Subject: bug: html export, latex fragments and emphasize
Newsgroups: gmane.emacs.orgmode
Date: Friday 12th November 2010 01:28:34 UTC (over 6 years ago)
Hello,

Here is a problem when a latex fragment is split across two lines and
an emphasize follows. The text won't be italicized upon exporting to
HTML.

=====
* latex-fragments bug

  Imagine we have a formula starting here $e^{i\pi} +
  1 = 0$. Now we have a problem with /emphasize/.
=====

This is because the line starts with a char with 'org-protected
property and, thus, get caught by the "Protected HTML" (org-html.el
l. 1216) part of `org-export-as-html'. In others words, the line is
inserted as-is in the output buffer, before getting any
transformation.

I'm not sure how it should be done (I don't get yet the usefulness of
this "Protected HTML" part), but that piece of code may be moved after
the `org-html-expand' call, as long as every sub-function in
`org-html-expand' has a check to prevent modifying protected stuff
(this not yet the case for `org-export-with-emphasize' and
`org-html-protect' while others seem ok).

But even in this case, every function getting called after that would
be ignored. So, for example, links would not be inserted.

Couldn't the "Protected HTML" part be removed altogether?

Regards,

--
Nicolas

_______________________________________________
Emacs-orgmode mailing list
Please use `Reply All' to send replies to the list.
[email protected]
http://lists.gnu.org/mailman/listinfo/emacs-orgmode
 
CD: 3ms