Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: David Beitey <david <at> davidjb.com>
Subject: Re: Timeout settings not respected
Newsgroups: gmane.comp.web.cherokee.general
Date: Wednesday 21st March 2012 00:37:36 UTC (over 5 years ago)
I've seemingly seeing the same issue with Cherokee 1.2.101 under RHEL 6.2,
using various information sources.   However, my tests seem inconsistent;
here's what I've found:

*General settings: *Cherokee timeout - 60 seconds

*Behaviour 1:* Main timeout setting respected -- times out at 60 seconds.

   - 'Default' rule for Behaviour
   - Handler is reverse proxy to remotely hosted information source
   - No SSL
   - No custom timeout
   - vServer matches on domain wildcard, no access logging, no SSL settings
   configured

*Behaviour 2: *Main timeout setting ignored and times out in 15 seconds

   - Regex and SSL rule for Behaviour
   - Handler is reverse proxy to remotely hosted information source
   - SSL
   - No custom timeout
   - vServer matches on Server IP, access logging is enabled, SSL cert/key
   configured

I'll obviously need to test further to try and narrow down if any of the
above options are the cause, but maybe someone else knows more about this.

-- David

On Sat, Mar 17, 2012 at 12:53 AM, Etienne Desautels
wrote:

>
> To whatever value I set the timeout setting
> (via
> general > network settings > timeout
> or
> vserver > behavior > restrictions > timeout),
> the server always timeout after 15 sec.
>
> It's with cherokee 1.2.101 on Ubuntu 10.04 with uwsgi (-t 600) and over
> SSL.
>
> Is this normal? How I'm supposed to fix that?
>
> Thanks
>
> Etienne
>
>
> _______________________________________________
> Cherokee mailing list
> [email protected]
> http://lists.octality.com/listinfo/cherokee
>
 
CD: 4ms