Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: jlan <joseluisalcazar <at> gmail.com>
Subject: Re: Trouble with get
Newsgroups: gmane.comp.web.cherokee.general
Date: Sunday 18th March 2012 08:21:19 UTC (over 5 years ago)
Sorry, cherokee list was discarting all my messages.

I used the wizard, in the same server i'm already moved sucessfully some
domains, a dozen of wordpress.
All but one with php enabled, all without problems.

cherokee                        1.2.2-2build1
php5-fpm                        5.3.6-13ubuntu3.6

Meanwhile I think i'll to do some probes with post (instead of get) to see
if it can work or fails too.


On Tue, Mar 13, 2012 at 02:04, Daniel Lo Nigro  wrote:

> How did you set up PHP? Did you use the wizard in Cherokee or did you set
> it up manually?
>
>   [image: PageUp People]
>  *Daniel Lo Nigro*
>  Web Developer
> Tel: +61 3 8677 3769
>
>
> On Mon, Mar 12, 2012 at 11:59 PM, jlan  wrote:
>
>> Sorry, i send the previous one not to the list.
>>
>> I mean, i visit this url:
>> http://mydomain/page.php?id=5
>> and in page.php you can get $_GET['id'] with value 5
>>
>> it works in apache, but i don't know why isn't working in cherokee, it
>> seems more cherokee and/or php related.
>>
>> Instead of  "echo $_GET['id'] " and it echoes  "5"
>>
>> I get this  "print_r($_GET)  and shows       Array ( [page.php?id] => 5
)
>>
>> Thanks for your help
>>
>> On Mon, Mar 12, 2012 at 06:40, Daniel Lo Nigro  wrote:
>>
>>> Sounds like you might be relying on the "MultiViews" feature of Apache?
>>>
>>> Is your file called "page.php"? If so, does going to
>>> http://myweb/page.php?pic=5 work?
Otherwise, where is "page" used? Is
>>> it a rewritten URL?
>>>
>>> On Tue, Mar 6, 2012 at 11:34 PM, jlan 
wrote:
>>>
>>>> Hi, I'm having a big time with cherokee and a web page that uses $_GET
>>>> to pass values , i was working in apache and same version of php.
>>>>
>>>> When i click the link http://myweb/page?pic=5 , the page
reload but
>>>> showing picture number 5, but  it fails to work.
>>>> I can't get the $_GET['pic'], only it gets a weird $_GET array with
>>>>  key/value   [page?pic] [5]
>>>> It seems maybe cherokee related but not sure.
>>>>
>>>> Thanks
>>>>
>>>>
>>>> _______________________________________________
>>>> Cherokee mailing list
>>>> [email protected]
>>>> http://lists.octality.com/listinfo/cherokee
>>>>
>>>>
>>>
>>
>
 
CD: 10ms