Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Benjamin Adler <benadler <at> gmx.net>
Subject: Support for Medion CTX953
Newsgroups: gmane.comp.video.video4linux
Date: Thursday 9th August 2007 10:37:56 UTC (over 10 years ago)
Hi!

I just got a Medion CTX 953_V.1.4.2 DVB-C/analog hybrid PCI-card (P/N 2003 
2576) and found it has these chips:

NXP SAA 7131E/03/G
CH1394
SF8510.1
TSG 07172

(DVB frontend chip?)
NXP TDA 10046A
SF9349.1
256
07151

(the analog chip?)
NXP 8275AC1
CMOS 38
TP607111

The card has an S-Video IN, an Audio-IN (3.5mm), and a Composite-IN, and
I'm 
tring to get it working on my Intel Core2Duo/Gentoo/amd64 machine with 
2.6.22-gentoo-r1.

lspci -vn says:
05:01.0 0480: 1131:7133 (rev d1)
        Subsystem: 16be:0010
        Flags: bus master, medium devsel, latency 64, IRQ 22
        Memory at ff9ff800 (32-bit, non-prefetchable) [size=2K]
        Capabilities: [40] Power Management version 2

lspci -v says:
05:01.0 Multimedia controller: Philips Semiconductors SAA7133/SAA7135 Video

Broadcast Decoder (rev d1)
        Subsystem: Creatix Polymedia GmbH Unknown device 0010
        Flags: bus master, medium devsel, latency 64, IRQ 22
        Memory at ff9ff800 (32-bit, non-prefetchable) [size=2K]
        Capabilities: [40] Power Management version 2

When I try "modprobe saa7134 tuner=54" I get the following stuff in dmesg:

saa7130/34: v4l2 driver version 0.2.14 loaded
saa7133[0]: found at 0000:05:01.0, rev: 209, irq: 22, latency: 64, mmio: 
0xff9ff800
saa7133[0]: subsystem: 16be:0010, board: UNKNOWN/GENERIC
[card=0,autodetected]
saa7133[0]: board init: gpio is 200000
saa7133[0]: i2c eeprom 00: be 16 10 00 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7133[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff 00 01 50 32 79 01 3c ca 50
saa7133[0]: i2c eeprom 20: 01 40 01 02 02 03 01 00 06 ff 00 2c 02 51 96 2b
saa7133[0]: i2c eeprom 30: a7 58 7a 1f 03 8e 84 5e da 7a 04 b3 05 87 b2 3c
saa7133[0]: i2c eeprom 40: ff 21 00 c0 96 10 03 22 15 00 fd 79 44 9f c2 8f
saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0

...but there still is no /dev/dvb.

I also have messages like these in dmesg:

saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0
DVB: registering new adapter (saa7133[0]).
DVB: registering frontend 0 (Philips TDA10046H DVB-T)...
tda1004x: setting up plls for 48MHz sampling clock
tda1004x: timeout waiting for DSP ready
tda1004x: found firmware revision 0 -- invalid
tda1004x: trying to boot from eeprom
tda1004x: timeout waiting for DSP ready
tda1004x: found firmware revision 0 -- invalid
tda1004x: waiting for firmware upload...
tda1004x: timeout waiting for DSP ready
tda1004x: found firmware revision d4 -- invalid
tda1004x: firmware upload failed
tda827x_probe_version: could not read from tuner at addr: 0xc0

So, my questions are:

 - Is this card supported? The DVB-C part? The analog part?

 - Which chips are for DVB-C, which are for analog TV?

 - I read somewhere I need to fetch "ttlcdacc.dll" and rename it 
to /lib/firmware/dvb-fe-tda10046.fw, which I did. Was that necessary? Was 
the .dll-file the wrong one, or why does it complain about "invalid
firmware 
revision"?

 - Which modules do I need for which parts (dvb/analog) to work? There's 
saa7134, saa7134_dvb, tuner, saa7134_alsa, tda827x, tda1004x, dvb_pll.

 - How do I make it work?

thanks for your help!
Ben Adler

P.S: this is the second time I'm sending this mail, the first one seems to 
have been lost somewhere.

--
video4linux-list mailing list
Unsubscribe mailto:[email protected]?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/video4linux-list
 
CD: 4ms