Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Michael Grollman <mgrollman <at> nscus.com>
Subject: Re: Issues with current subtitler filter in 1.0.2 build
Newsgroups: gmane.comp.video.transcode.user
Date: Friday 16th December 2005 23:38:30 UTC (over 10 years ago)
>
> I am a newbie using Transcode 1.0.2, and I am trying to take mkv files 
> which have an mpeg4 video track, an ac3 audio track, and an srt 
> subtitles track, and burn them to a dvd format playable in a standard 
> dvd player.  The mkv file I start with plays fine in many players 
> under linux and windows, so I am pretty confident in my course material.
>
> Through a lot of help from the transcode Wiki and the avitovob script, 
> somewhat tweaked, I have been able to get the video and audio portions 
> all the way through to a readable dvd.  I am also able (with 
> mkvextract) to pull out my nice readable .srt file, and I can convert 
> this to a ppml file OK.
>
> _But I am having a very rough time getting the subtitles_.  The quick 
> version of the story is that when I try the line:
>
>     -J subtitler="subtitle_file=$file.ppml" \                    # 
> (detailed version of the full command is below)
>
> I get an warning from transcode to the effect that:
>
>     [transcode] warning : loading filter module
>     /usr/local/lib/transcode/filter_subtitler.so failed
>     [transcode] warning :
>     /usr/local/lib/transcode/filter_subtitler.so: cannot open shared
>     object file: No such file or directory
>
> And in fact, there /is /a file 
> /usr/local/lib/transcode/filter_subtitler.so.
>
>  But other than this, transcode is running fine in every way.
>
> I am building transcode from source on an amd64 box using the current 
> version of debian testing.  I am using this line to configure build 
> transcode (though I have tried lots of other combos here):
>
> ./configure --enable-shared --enable-freetype2 \
> --enable-mjpeg --enable-dvdread --enable-libmpeg3  \
> --enable-libxml2 --enable-magick --enable-libjpeg \
> --enable-imagemagick --enable-mjpegtools --enable-libxml2 \
> --enable-sdl --enable-gtk
>
>
> I do not see any errors when I run this make / make install  (though 
> lots of warnings).  And I get no seg faults, and otherwise, transcode 
> seems to work OK, other than not rendering subtitles with this tool..
>
> I have tried a to download a variety of versions from CVS and 
> elsewhere of the subtitler (some of which appear to be older than 
> 1.0.2, some newer), but none of them compile the library  right for me.
>
> In short, can anyone tell me what I am doing wrong in trying to get 
> this subtitler to build, or else suggest a cleaner way to get the srt 
> stuff into my dvd burn?
>
> Much thanks.
>
> -----------------------
> Exact command that produces the error:
>
>
>  transcode --nice 20 \
>            --print_status 500 \
>            -x mplayer,null \
>            -y ffmpeg,null \
>            -F mpeg2video \
>            -e 48000,16,2 \
>            --export_asr 2 \
>            --export_fps 29.970 \
>            --export_prof dvd-ntsc \
>            -Z 720x480,fast \
>            -J subtitler="subtitle_file=$file.ppml" \
>            -j -16,-32,-16,-32 \
>            -o output \
>            -i output.avi
>
>
>  (note - I connverted the srt to a ppml before this runs).
>
> ----------------------------
>
> Output from the ./configure command
>
> ----------------------------

(I had to remove the first part of this ouput becuase of the 40K limit 
on this board.

> ----------------------------------------
> Summary for transcode 1.0.2:
> ----------------------------------------
>
> core options
> ----------------------------------------
> static AV-frame buffering      yes
> network (sockets) streams      no
> experimental xio               no
> Default xvid export            xvid4
> A52 default decoder           
>
> libavcodec
> ----------------------------------------
> headers                        -I/usr/include
> libraries                      -L/usr/lib -lavcodec -lm -lz -lpthread
> build                          3342336
> version                        CVS
> statically linked              no
>
> hardware support
> ----------------------------------------
> v4l/v4l2                       no
> OSS                            no
> bktr                           no
> sunau                          no
>
> optional package support
> ----------------------------------------
> IBP                            no
> X11                            yes
> libmpeg2                       yes
> libpostproc                    no
> freetype2                      yes
> avifile                        no
> lame                           yes
> ogg                            no
> vorbis                         no
> theora                         no
> libdvdread                     yes
> pvm3                           no
> libdv                          no
> libquicktime                   no
> lzo                            no
> a52                            no
> libmpeg3                       yes
> libxml2                        yes
> mjpegtools                     yes
> sdl                            yes
> gtk                            yes
> libfame                        no
> imagemagick                    yes
> libjpeg                        yes
> bsdav                          no
> iconv                          yes
>
>
>
 
CD: 4ms