Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Francesco Romani <francesco.romani <at> email.it>
Subject: patch for "glibc detected: double free or corruption" problem in tccat
Newsgroups: gmane.comp.video.transcode.user
Date: Sunday 20th November 2005 22:47:11 UTC (over 12 years ago)
Hi all,

users affected by problem mentioned in the subject please try attached
patch. It's against release 1.0.2.
This patch requires to compile transcode from source.

install instructions:
1. use a fresh copy of transcode 1.0.2 (see http://www.transcoding.org
to get a new one)
2. grab the attached patch
3. unpack the transcode tarball, enter in transcode base directory and
apply the patch. Example:
cd transcode-1.0.2
patch -p0 < /path/to/tccat-CVS-iodir-backport-try1.patch
4. reconfigure and rebuild transcode and install as you wish
5. test patched transcode (or at least tccat) against offending source

please do not strip debug symbols from test binaries (it's the default
to install binaries _with_ debug symbols, so you must drop it
explicitely; pleas don't :))

if patch doesn't solve the issue, please provide a gdb backtrace using
generated core file:

gdb binary core (binary should be 'tccat')
do 'bt' at gdb prompt and post the output.

Regards,

-- 
Francesco Romani - Ikitt 
'people always complain, no matter what you do'
contacts: jabber://ikitt-at-jabber-dot-linux-dot-it
icq://27-83-87-86-7
 
CD: 4ms