Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Alberto Bertogli <albertogli <at> telpin.com.ar>
Subject: darcsweb 0.15-rc1 and a security fix
Newsgroups: gmane.comp.version-control.darcs.user
Date: Friday 24th February 2006 01:50:39 UTC (over 11 years ago)
Hi!

It's time for a new release. However, as this one incorporates many
changes to critical code (encoding handling), I'm putting up an -rc so
you can test it and let me know about any regresions (or the lack
thereof).

Among the benefits of the new code, you can use multiple encodings, and
if one fails, the next one is used, and so on. This is important to
people using multirepos with several different encodings, and the ones
who have a single repository that has changed encodings over time.

If you have only english/ascii repositories, you won't probably feel the
difference (although there are other changes that might be of intrest).


It also includes a very important security fix that you should pull,
regardless of trying out the new changes.


It has received some testing from me and a couple of others, so I think
it's safe to try; but I'd still like broader testing before releasing
it. If you use it, please let me know how it goes.

Finally, you can browse an updated darcsweb repository at
http://www.luca.homeip.net/~luca/repos/darcsweb/?r=darcsweb;a=summary,
thanks to Leandro Lucarella who offered to host it.

As usual, suggestions and requests are more than welcome =)

Thanks a lot,
		Alberto
 
CD: 95ms