Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: A.L.E.C <alec <at> alec.pl>
Subject: Re: minimum PHP version
Newsgroups: gmane.comp.php.pear.qa
Date: Tuesday 3rd January 2012 08:02:10 UTC (over 5 years ago)
On 02.01.2012 23:16, Daniel O'Connor wrote:
>> I am not sure how aware many of you guys are of how many PHP 4 users we
>> still have using the PEAR installer
>>
> 
> We're not really clear on it - got stats? It would be good to see the
> numbers.

Not about PEAR, but about PHP-supported servers according to
http://reviews.gcoupon.com/browse/servers/Website_Servers.html

PHP4: 17603 (17%)
PHP5: 88755 (83%)

BC-break rule was good 5 years ago, now we should get rid of it.

- Most likely none of PHP4 users care about updates,
- This rule stops some PEAR developers from being more active (like me),
- This rule stops progress also because new packages (*2) are not used
immidietly by distributions, and the process requires some time to
stabilise the new code.

Let's do it, please.

-- 
Aleksander 'A.L.E.C' Machniak
LAN Management System Developer [http://lms.org.pl]
Roundcube Webmail Developer  [http://roundcube.net]
---------------------------------------------------
PGP: 19359DC1 @@ GG: 2275252 @@ WWW: http://alec.pl

-- 
PEAR QA Mailing List (http://pear.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php
 
CD: 3ms