Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: petros <pmamales <at> nyc.rr.com>
Subject: Re: compessed_matrix updating issue
Newsgroups: gmane.comp.lib.boost.ublas
Date: Wednesday 29th February 2012 19:55:47 UTC (over 5 years ago)
Thx, Thomas!
Have not forgotten, did not know ! ;- ))
The documentation is rather scarce. Any pointer ?
Again thx a bunch,
P-

-----Original Message----- 
From: Thomas Klimpel
Sent: Wednesday, February 29, 2012 2:47 PM
To: ublas mailing list
Subject: Re: [ublas] compessed_matrix updating issue

petros wrote:
> I have a compressed_matrix column oriented matrix.
> I reead a Harwell Boeing file, so I can know its sizes and 
> nbrNon0Elements, as well
> .the index arrays and the value data.
> So I create my matrix, and obtain references to the 3 arrays
> which I fill manually (i.e. by reading the file).
> Upon inspection of the matrix arrays, I see everything to be OK
> ( as expected) but the subscript operator gives 0’s.
> Also it appears the the iterators are invalidated – not sure about this

> though.
> Apparently there has to be a mechanism to  “lock” things down.
> What do I need to do ?

I guess you have "forgotten" to call "set_filled"...

Regards,
Thomas
_______________________________________________
ublas mailing list
[email protected]
http://lists.boost.org/mailman/listinfo.cgi/ublas
Sent to: [email protected] 


_______________________________________________
ublas mailing list
[email protected]
http://lists.boost.org/mailman/listinfo.cgi/ublas
Sent to: [email protected]
 
CD: 4ms