Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Johannes Waldmann <waldmann <at> imn.htwk-leipzig.de>
Subject: hsql[-mysql]
Newsgroups: gmane.comp.lang.haskell.libraries
Date: Thursday 8th January 2009 07:41:20 UTC (over 8 years ago)
can we fix the situation with hsql[-mysql]?

it seems there are three versions, all named "-1.7",
and none of them working with recent ghc:

* http://htoolkit.sourceforge.net/
original project site
* http://hackage.haskell.org/cgi-bin/hackage-scripts/package/hsql
  (build failures with ghc-6.8, 6.10)
* http://code.haskell.org/HSQL/  
current maintainer's site
  (build failures with 6.10)

Since I needed this, I adapted the *.cabal and Setup.hs
so they work with ghc-6.8 and 6.10.

Since I posted this remark
http://article.gmane.org/gmane.comp.lang.haskell.libraries/10299
I got several requests for these.

So I'm making them available here provisionally (named *-1.7.1):
http://dfa.imn.htwk-leipzig.de/~waldmann/draft/HSQL/

... but of course this only adds to the confusion.

best regards, J.W.
 
CD: 3ms