Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Wiktor =?ISO-8859-2?B?R3LqYmxh?= <greblus-Re5JQEeQqe8AvxtiuMwx3w <at> public.gmane.org>
Subject: Re: lirc doesn't work (Lifeview FlyVideo 98FM LR50) (SOLVED)
Newsgroups: gmane.comp.hardware.lirc
Date: Sunday 7th January 2007 19:34:18 UTC (over 11 years ago)
On Sat, 30 Dec 2006 10:07:15 +0100
Wiktor Grębla  wrote:

> If anyone has similar configuration working on 2.6.19 I'd love to know
:). 

Finally I have it working.

Something must have changed in the recent kernels. My card isn't
automatically 
detected when loading bttv module (and never was), so I was loading the
module 
with card=56 modprobe option (other ids were also working for the tv, but
the remote 
(AFAIR) worked best with this one). It was working, but recently
something's changed 
(somwhere between 2.6.16 - 2.6.19). mode2 -d /dev/lirc0 showed that there
was nothing 
going on  when buttons were pressed.

I started fiddling with different card ids and with card=35 mode2 outputed
some keycodes. 
That was it.

All I had to do, was to generate a new lircd.conf using irrecord. Now it
works even better 
than before (i can press buttons when the remote is in an arbitrary
position).

lspci says it's 01:0a.0 Multimedia video controller: Brooktree Corporation
Bt878 Video Capture 
(rev 11), the card is a flyvideo 98 with fm tuner. I suppose it's not
widely used, but maybe someone 
will have similar problem and will find it useful.

Now i've a perfectly working Arch installation (lirc was the last thing
missing from my previous distro).

Attached is the automatically generated lircd.conf file (at least the keys
i use). 

Regards,
W.

-- 
Talkers are no good doers.
http://greblus.net/djangoblog/
 
CD: 3ms