Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Chandler Carruth <chandlerc <at> gmail.com>
Subject: Build-bot host compiler upgrades and C++11!
Newsgroups: gmane.comp.compilers.llvm.devel
Date: Tuesday 7th January 2014 09:40:35 UTC (over 3 years ago)
Greetings, starting a new thread and CC-ing all the folks I could think of
that are likely running bots for LLVM. If I've missed any, sorry, please
add them.

As lots of folks have been mentioning, it's time to switch LLVM (and most
subprojects) to use C++11. The first step is establishing a new baseline of
compiler versions that are supported[1]:

MSVC 2012
GCC 4.7
Clang 3.1

If you are helping to keep our build bot infrastructure running and
up-to-date, please check the host compiler versions and reply here if
you're going to have trouble upgrading. My rough plan based on chatting
with some folks is to submit checks to cmake and configure on Monday to
produce an error on older toolchains without some flag to force old
toolchain support.

So reply to this thread if you need more time, or if all your bots are
ready-to-go! Thanks a bunch!
-Chandler


[1]: Most of these compilers were available in the middle (June) of 2012,
and based on the planned 3.5 release time frame of the middle of 2014, that
will mean a roughly two year spread of compiler releases. MSVC 2012 was
later, but the community seems comfortable with requiring the upgrade.
Also, these versions include very significant improvements that make
adopting C++11 features much more viable. This was discussed at some length
on the mailing list, and I'm not really trying to re-open debate here, just
reminding folks. =]
 
CD: 3ms